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About the TGA 

 

The Tactile Graphics Assistant (TGA) is a software tool created by members of the Tactile Graphics 

Project to assist in the text removal stage of the visual-to-tactile image conversion process.  

Currently, the primary function of the TGA is to detect and remove text from large batches of 

digital images.  The TGA takes advantage of the fact that images from the same textbook possess 

many similar qualities, such as text style, shading, and label placement.  A small subset of images is 

selected from the textbook to form a training set.  The user indicates the location of the text – 

individual characters as well as meaningful labels – in each image.  The TGA will then be “trained” 

on this data. The TGA then uses the training set data to automatically detect characters and labels in 

the remaining images.  If errors occur during this procedure, the user can make changes to the 

TGA’s selections.  Once text removal has been successfully completed, the TGA will output files 

that can be used in other stages of the image transcription process. 

 

 

Tactile Graphics Workflow 

 

In order to create tactile graphics using the TGA, you will need several other pieces of software: 

 Image editing software, such as Adobe Photoshop CS2 and Adobe Illustrator CS2 

 OCR software, such as Scansoft Omnipage, or Infty Reader (in the case of mathematical 

figures) 

 Braille translation software, such as Duxbury 

It is important to note that currently the TGA workflow has only been tested with the software 

mentioned above. If you use other image editing software, for instance, the scripts designed for 

Photoshop and Illustrator will not work.
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TGA Main Screen Overview 

 

The main screen of the TGA is where images are displayed and processed.  This is what the main 

screen looks like when the TGA is first opened: 

 

 
The main screen of the TGA. 

 

When an image is loaded, it appears in the display area of the main screen (see image below).  If the 

image does not fit in the display area, scroll bars will appear.  The name of the image file appears in 

the heading bar at the top of the screen. 

 

Notice in the screenshot below that the “Character Mode” radio button is selected.  When images 

are opened, the TGA automatically switches to Character Mode. 

 

 
The TGA main screen with an image loaded. 
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File Menu Overview 

 

This section provides an overview of all the commands listed in the File menu (opened below). 

 

 
The File menu. 

 

General Options:  See detailed description on next page.  Allows the user to configure TGA 

settings including paper size, DPI, and image folders. 

 

Load:  Enables the user to choose an image to load into the TGA.  A dialog box will appear with 

browsing options. 

 

Load Previous:  Loads the previous image in the designated input folder (set in General Options). 

 

Load Next:  Loads the next image in the designated input folder (set in General Options). 

 

Save:  Saves character and label selections in the current image.  Saved data is stored in the 

designated intermediate folder (set in General Options). 

 

Close:  Closes the current image. 

 

Batch Process:  Automatically identifies characters and labels in all images in the designated input 

folder (set in General Options), generates output for each image, and then saves the changes made.  

This is the equivalent of manually opening every image in the folder and clicking the Mark 

Characters & Labels command in the Execute menu. Currently it is not possible to cancel a batch 

process. 

 

Exit:  Exits the TGA.  All training data accumulated in this session will be lost.  Individual image 

data will be retained. 
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General Options Dialog Overview 

 

The General Options dialog box can be accessed from the General Options command in the File 

menu. 

 

 
The General Options dialog box. 

 

Page width in inches:  Specifies the paper width. 

 

Page height in inches:  Specifies the paper height. 

 

Target dots per inch (DPI):  Specifies the DPI. 

 

Preserve Aspect Ratio:  Specifies whether or not to preserve the width/height ratio of the image on 

resize. 

 

Input:  Enables the user to designate a specific folder as the “input” folder.  When the Batch 

Process command is selected, the TGA will automatically open and process each image in the 

designated “input” folder.  In addition, when Load is selected, the browsing dialog box will display 

the designated “input” folder. 

 

Intermed:  Enables the user to designate a specific folder as the “intermediate” folder.  When the 

Save command is selected, the data for the current image will be saved in this folder. 

 

Output:  Enables the user to designate a specific folder as the “output” folder.  When the Mark 

Similar or Mark Characters & Labels  commands are selected, the output files generated for each 

image will be saved in this folder. 

 

Levels of undo:  Specifies the number of previous program states stored in the undo database.  If 

“3” is entered, the user can select the Undo command up to three times, enabling him or her to undo 

the past three actions. 
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Mode Menu Overview 

 

This section provides an overview of all the commands listed in the Mode menu (opened below). 

 

 
The Mode menu. 

 

As long as an image is opened in the image display window, the TGA will be in either Character 

Mode or Label Mode.  The radio buttons on the main screen perform the same functions as the 

commands in the Mode menu (see image below). 

 

Character Selection:  Enables the user to designate elements in the current image as characters. 

Label Selection:  Enables the user to group characters into text labels. 

 

 
The mode selector radio buttons enable the user to switch between Character Mode and Label Mode. 
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Train Menu Overview 

 

This section provides an overview of all the commands listed in the Train menu (opened in the 

image below). 

 

 
The Train menu. 

 

Update Positive:  Available in both Character Mode and Label Mode.  Updates the training 

database with positive examples selected.  If this command is selected in Character Mode, 

everything in the image that has been selected as a character will be added to the training database 

as examples of graphical elements that are characters.  If this command is selected in Label Mode, 

groupings of characters that have been selected as labels will be added to the training database as 

examples of labels. 

 

Update Negative:  Only available in Character Mode.  Updates the training database with negative 

character examples.  If this command is selected, everything in the image that has not been selected 

as a character will be added to the training database as examples of graphical elements that are not 

characters. 

 

Update Positive and Negative:  Only available in Character Mode.  Updates the training database 

with both positive and negative character examples.  If this command is selected, everything in the 

image that has been selected as a character will be added to the training data base as examples of 

graphical elements that are characters, and everything that has not been selected as a character will 

be added to the training database as examples of graphical elements that are not characters. 

 

Update All: Characters & Labels:  Available in both Character Mode and Label Mode.  Updates 

the training data base with both positive and negative character examples and examples of labels.  If 

this command is selected, everything in the image that has been selected as a character will be 

added to the training data base as examples of graphical elements that are characters, and everything 

that has not been selected as a character will be added to the training database as examples of 

graphical elements that are not characters.  Groupings of characters that have been selected as labels 

will be added to the training set as examples of labels. 
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Train Menu Overview (continued) 

 

Clear Statistics:  Clears either all characters or all labels from the training set, depending on the 

current mode.  Positive and negative statistics sets are cleared. 

 

Clear All Statistics:  Clears both characters and labels from the training set.  Positive and negative 

statistics sets are cleared. 

 

Options:  See image below.  Enables the user to choose the color(s) of characters identified by the 

TGA.  The “color picker” box (on the left side of the dialog) lists the color(s) of characters the user 

wishes the TGA to identify.  In the example below, “0 0 0” (representing the color black) is the only 

color listed.  To add colors to the color picker list, click on a section of the image that contains the 

desired color.  To delete a color from the list, click on that entry in the list and press the “Delete 

Selected” button.  The controls on the right side of the dialog box (labeled “SVM/Old Character 

Classification” and “Old Character Classification Only”) were used for testing in the creation of the 

TGA and should not be modified. 

 

 
The “color picker” dialog box. 
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Execute Menu Overview 

 

This section provides an overview of all the commands listed in the Execute menu (shown opened 

in the image below). 

 

 
The Execute menu. 

 

Mark Similar:  Available in both Character Mode and Label Mode.  If in Character Mode, 

automatically identifies characters based on the current training set.  If in Label Mode, 

automatically identifies labels based on the current training set. 

 

Mark Characters & Labels:  Automatically identifies all characters and labels based on the current 

training set. 

 

Clear Marked:  Available in both Character Mode and Label Mode.  If in Character Mode, “un-

marks” all selected characters.  If in Label Mode, “un-marks” all selected labels. 

 

Clear Characters & Labels:  Automatically “un-marks” all selected characters and labels. 

 

Undo:  Erases the results of the last action completed. 
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View Menu Overview 

 

This section provides an overview of all the commands listed in the View menu (shown opened in 

the image below). 

 

 
The View menu. 

 

 

State Information:  Opens a dialog box that lists information about the current training set, 

characters and labels selected in the current image, and other statistics. 

 

Hide Selected Characters:  When this option is checked, all the selected characters in the image are 

hidden.  See image above. This option is also available directly from the main screen, by checking 

or unchecking the “Hide Selected Characters” checkbox. 
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Selecting Characters 

 

Select any letters, numbers, and symbols in the image that you want to remove from the image and 

translate to Braille.  Once selected, these characters will be enclosed in a red box on the main screen 

of the TGA.  Don’t forget to select punctuation, as well as the dots on “i”s and “j”s. 

 

 
A red box indicates letters/numbers/symbols designated as characters. 

 

Selecting characters is easy and can be done quickly.  For large patches of text with no interfering 

graphical elements, simply drag the mouse over the whole patch (see image below); all the text will 

be selected as characters. 

 

 
Large groups of letters and symbols can be selected as characters at the same time. 

Be careful not to select any unwanted graphical elements. 
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Selecting Labels 

 

A set of characters that will function as one Braille label should be grouped together as a label.  

Once selected, labels will be enclosed in a blue box on the main screen of the TGA.  The characters 

in each label will be output by the TGA together, so they can be directly sent to translation 

software. 

 

 
A blue box indicates characters grouped as a label. 

 

To group characters into a label, drag the mouse over the group of selected characters you want to 

designate as a label (see image below).  The TGA will only look for selected characters in the area 

you highlight, so it’s OK if you accidentally highlight other non-character graphical elements (as in 

the image below). 

 

 
Complete accuracy is not required for label selection. 

Only selected characters in the highlighted area will be grouped in the label. 

In this image, the letters will be grouped as a label, but other graphical elements will be ignored. 
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How to Use the TGA 

 

This section guides the user through the process of editing a batch of images using the TGA.  

 

Step 1:  Set Up Images and Directories 
1. Scan hard copy images at 300 dpi. 

2. Work images must be in BMP, 24-bit RGB. 

a. TGA will only accept this format 

3. Threshold operation might be needed for clean, solid color text. 

a. TGA works best with clean images with solid text. 

b. It is recommended to “clean up” images before opening them in TGA. 

4. Create folders for TGA operation – These folders can be created manually, or by running 

runFolderSetup.bat in the target directory. 

a. Create an “Input” folder.  Place a copy of each image in your image set in here. 

b. Create an “Intermediate” folder.  Leave this empty. 

c. Create an “Output” folder.  Leave this empty. 

 

Step 2:  Configure TGA Settings 

1. Make sure your computer has at least 1GB of memory for proper performance. 

2. Open the “General Options” window: 

a. File → General Options, or 

b. Press “Ctrl”+”O” 

3. In the pop-up window (see image below) set the following values: 

a. Page Width:  Output paper width 

b. Page Height:  Output paper height 

c. Target DPI:  Output image resolution 

d. Preserve Aspect Ratio:  Whether the image should retain its width/height ratio on 

resizing. 

e. Input:  Point this to the “Input” folder you created in Step 1 

f. Intermediate:  Point this to the “Intermediate” folder you created in Step 1 

g. Output:  Point this to the “Output” folder you created in Step 1 

h. Undo Level:  Use default value 

i. When done, press “OK.” 

 

 
The “General Options” dialog box. 
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How to Use the TGA (continued) 

 

Step 3:  Load Images 
1. Make sure “Input”, “Intermediate”, and “Output” folders are properly selected in General 

Options. 

2. Load image: 

a. File → Load, or 

b. Press “Ctrl”+”L” 

3. To load the next image in the “Input” folder, press “Page Down”. To load the previous 

image, press “Page Up.” If you wish to save the work you’ve done on the current image, 

make sure to do so before moving on to the next (File → Save, or “Ctrl” + “S”) 

4. Whenever an image is loaded, the TGA creates files associated with the image in the 

“Intermediate” folder for future efficiency. 

5. If an image is modified in any way after opened in the TGA, open the “Intermediate” folder 

and delete all files that contain the name of the modified image. 

 

Step 4:  Character Selection 

1. To enter character selection mode: 

a. Select the “Character Mode” bullet, or 

b. Mode → Character Selection, or 

c. Press “1” 

2. Set pixel color(s) to be selected:  

a. Train → Options, or 

b. Press “O” 

3. In the pop-up box (see image below), set the pixel value by clicking on a part of the image 

with the appropriate pixel color. Multiple values are allowed. 

4. The TGA will only select characters whose color is similar to the selected pixel color(s). 

5. To select characters, draw a selection box by clicking and dragging the mouse pointer over 

the image part deemed to be characters (see image at top of next page). Selected characters 

will be marked with a red box. 

6. The selection acts as a toggle, meaning it will select unselected characters and deselect 

previously selected ones. 

7. Holding “Ctrl” while drawing a selection box will deselect every character within the 

selection box. 

 

 
The “color picker” dialog box. 
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How to Use the TGA (continued) 

 

 
Selecting characters in an image. 

 

Step 5:  Label Selection 
1. To enter label selection mode: 

a. Select the “Label Mode” bullet, or 

b. Mode → Label Selection, or 

c. Press “2” 

2. To select labels, draw a selection box by clicking and dragging the mouse pointer over the 

characters that should be grouped together (see image below). Selected labels will be 

marked with a blue box. 

3. Deselect labels by drawing a selection box over a part of the label. 

4. Holding “Ctrl” while clicking and dragging will group characters that lie within a straight 

line between the start point (where the mouse is pressed) to the end point (where the mouse 

is released). 

5. Holding “Shift” while clicking and dragging will group characters that cross the path of the 

mouse pointer. 

 

 
Grouping selected characters into a label. 
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How to Use the TGA (continued) 

 

Step 6:  Saving Images 
1. When characters and labels are properly selected, save the image: 

a. File → Save, or 

b. Press “Ctrl”+”S” 

2. TGA will produce three files for the image in the “Output” folder: 

a. filename.BmpErasedCCs.bmp: The image with text removed. 

b. filename.SelLabelsNoBoxes.bmp: The text as image. 

c. filename.SelMBs.xml: XML Location and scale factor information. 

3. It is important to remember to save as the TGA does not prompt users to save when loading 

another image. 

 

Step 7:  Training 
1. Training can be done for characters and labels separately, or combined. 

2. For separate training, enter the appropriate mode. There are three methods: 

a. Train → Update Positive: Selected characters/labels will be added to the correct 

examples. 

b. Train → Update Negative: Selected characters will be added to the incorrect 

examples. (Disabled for Label Mode) 

c. Train → Update Positive and Negative: Selected characters will be added to the 

correct examples, unselected characters to the incorrect examples. (Disabled for 

Label Mode) 

3. For combined training, Train → Update All: Selected characters will be added to the correct 

character examples, unselected characters to the incorrect character examples, selected 

labels to the correct label examples. 

4. To use training data: 

a. Execute → Mark Similar or Press “M”: Depending the one mode, automatically 

selects characters or labels. 

b. Execute → Mark Characters and Labels or Press “Ctrl”+”M”: Automatically selects 

both characters and labels. 

5. To save training data, Training → Save Statistics. 

6. To load training data, Training → Load Statistics. 

7. A large training data could take up memory and significantly slow down the TGA. When 

not in use, it is useful to remove the training data: Training → Clear All Statistics. 

 

Step 8:  Batch Processing 
1. Make sure the training data is loaded. 

2. Make sure “Input,” “Intermediate,” and “Output” are pointed to the correct folders. 

3. File → Batch Process 

4. For each image in the input folder, TGA will automatically select characters, select labels, 

and save the image. 

5. Processing time depends on the size of the image and the number of connected components 

in the image. 

6. Note that currently it is not possible to cancel or undo a batch process once it has begun. 
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Using the TGA as Part of the Image Translation Process 

 

The TGA was designed for use as one component a tactile graphics translation workflow.  In this 

workflow, different software tools automate steps in the tactile graphics translation process. 
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Using the TGA as Part of the Image Translation Process 

 

Step 1:  Preliminary 
 

1. Scan hard copy images at 300 dpi 

2. Work images must be in BMP, 24-bit RGB 

3. Threshold operation might be needed for clean, solid color text.  See the Preprocessing 

Images with Adobe Photoshop section on page 26 

4. If the image has something like a legend with very small textured areas, these may need 

to be enlarged and put back in to the image using Photoshop 

5. Choose descriptive filenames. For example, use figure numbers or page numbers, or 

some other sensible indexing scheme. 

 

Step 2:  Classification 

 

1. Classify images with similar features 

2. Within each class, group images in sets of 10-20 

3. Within each set, create an “Input” folder, an “Intermediate” folder, and an “Output” 

folder – you can do this manually, or by copying “folderSetup.pl” and 

“runFolderSetup.bat” to the current directory and double clicking the “.bat” file. 

4. Within each set, move the images to the “Input” folder 

5. For each class, create a “Training” folder 

6. Within the “Training” folder, create an “Input” folder, an “Intermediate” folder, and an 

“Output” folder 

7. Select several representative images of the class and put them in “Training\Input” 

 

Step 3:  TGA – Repeat the steps for each class 

 

(See the How to Use the TGA section on page 14 for more details on each step) 

 

1. Setup 

a. Open TGA 

b. Set “Input” to be the “Training” folder 

c. Set “Intermediate” and “Output” to the proper folders 

2. Training 

a. Load an image from “Input” 

b. Mark all characters in the image 

c. Mark all the labels in the image 

d. Save the file 

e. Update the training data 

f. Repeat the step for the other images in the training set 

g. Save the training data 

3. Batch 

a. Set “Input” to be one of the set of 10-20 images 

b. Select “Batch Mode” 

4. Edit 

a. Check for errors in each image of the set 

b. After errors are corrected, save the image 

c. If a mistake is consistent, update the training data 

d. Repeat the batch and edit steps for the other sets 
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Using the TGA as Part of the Image Translation Process (continued) 

 

Step 4:  OCR – Repeat the steps for each set 

 

(We use OmniPage Pro OCR software for this step.  However, other OCR software can be 

used.  Most popular OCR software tools have similar batch processing capabilities.) 

 

1. Batch 

a. Copy files with the extension “SelLabelsNoBoxes.bmp” from “Output” into a 

new folder, “Text” 

b. Open OmniPage Batch Manager 

c. Create a new Job 

d. Set “Load Image Files” as the first step (see left image below)  

e. Load the images from “Text” (see right image below) 

 

    
OmniPage OCR Batch Process Step 1: Load Image Files 

 

f. Set “Recognize Images” as the second step (see images below) 

 

    
OmniPage OCR Batch Process Step 2: Recognize Images 
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Using the TGA as Part of the Image Translation Process (continued) 

 

Step 4:  OCR (continued) 

 

g. Set “Save as OPD” as the third step. Set the save folder to be “Text”  (see images 

below) 

 

    
OmniPage OCR Batch Process Step 3: Save as OPD 

 

h. Set “Finish Job” as the final step (see images below) 

i. Start the Job 

 

    
OmniPage OCR Batch Process Step 4: Finish Job 
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Using the TGA as Part of the Image Translation Process (continued) 
 

Step 4:  OCR (continued) 

 

2. Edit 

a. Open the saved OPD document 

b. Go to View. Set the “Page Image”, “Text Editor”, and “Thumbnail Image” to be 

visible 

c. Change font to OCR A Extended in Text Editor 

d. Make sure all text is the same font- if lighter grey, fix. 

e. Go through each image and compare the image to the OCR result 

f. Edit OCR result as necessary 

g. Math needs to be done with LaTex 

h. Surround LaTex code with ‘$’ 

i. Go to File → Export Result → Save to File (see image below) 

j. Set “Files of type” to “Text with line breaks (*.txt)” (see image on next page) 

k. Set “File options” to “Create a new file for each image file” (see image on next 

page) 

l. OK 

 

 

 

 

 
How to find the “Save to File” command. 
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Using the TGA as Part of the Image Translation Process (continued) 
 

Step 4:  OCR (continued) 

 

 
How to set up the “Save to File” dialog box 

 

3. Line count check 

a. Copy the proper xml files to “Text” 

b. Copy “numlines.pl” and “runnumlines.bat” to “Text” 

c. Execute “runnumlines.bat” 

d. An output window will list files with incorrect number of lines 

4. Backup 

a. Backup the edited textfiles in “Text” to a separate folder 

5. Optional: Latex 

a. If textfiles have Latex tags, textfiles need to be prepared for proper processing 

b. Copy “appendlatex.pl” and “appendlatex.bat” to “Text” 

c. Run “appendlatex.bat” 
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Using the TGA as Part of the Image Translation Process (continued) 
 

Step 5: Braille Translation – Repeat the steps for each set 

 

(We use Duxbury Braille Translator for this step.  Other Braille translation software can be 

used, but care must be taken to ensure that the resulting Braille document has the same 

number of lines as the original.) 

 

1. Process 

a. Open Duxbury 

b. Load a text file from “Text” 

c. At the same time, open the same text file in a text editing program. 

d. Press Ctrl+T to translate into Grade 2 Braille 

e. Select the translated text in Duxbury and copy 

f. In the text editing program, paste the translated text 

g. Pasting the text will create a blank first line, delete it 

h. Save 

i. Repeat for the rest of the text files in the folder 

2. Line count check 

a. Execute “runnumlines.bat” 

b. An output window will notify files with incorrect number of lines 

 

Step 6: Resize Images – Repeat steps for each set 

 

1. Open Photoshop 

2. Go to File → Scripts → Browse → Scale Batch (see image below) 

3. Set the work folder to be “Output” 

 

 
How to navigate to the “script selection” menu item. 
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Using the TGA as Part of the Image Translation Process (continued) 

 

Step 7: Label Placement – Repeat steps for each set 

 

1. Setup 

a. Create two new folders, “Ready” 

b. Move images with extension “Resized.bmp” to “Ready” 

c. Copy the proper xml files to “Ready” 

d. Copy the proper textfiles to “Ready” 

2. Batch 

a. Open Illustrator 

b. Go to File → Scripts → Browse → Braille Insert Batch 

c. A window will pop up asking for a source folder.  Set this to be “Ready” 

d. Another window will pop up asking for a destination folder.  Set this to be 

“Ready” 

3. Check scales 

a. Load an illustrator file from “Ready” 

b. Make note if the image needs to be resized to fit the Braille 

c. Repeat for all the files 

 

Step 8: Editing in Photoshop – Repeat for each set 

 

1. Open Photoshop 

2. Load a “Resized.bmp” image from “Ready” 

3. Remove unnecessary colors 

4. Remove or simplify visual decoration 

5. Replace meaningful colors with textures. This can also be done in Illustrator if desired. 

6. Repeat for the other images 

 

Step 9: Editing in Illustrator – Repeat for each set 

 

1. Edit images 

a. Open Illustrator 

b. Load an Illustrator file from “Ready” 

c. Move the textboxes around to fit 

d. Break long text into separate lines when needed and possible 

e. Create white space to obscure parts of the image when needed and possible 

f. Enlarge the workspace if more space is needed. Do not go over 16”x50”. Try to 

keep it under 16”x30”Create new textboxes to add necessary info 

g. Repeat for the other Illustrator files 

2. Embed (bundles Photoshop and Illustrator files together) 

a. Open Illustrator 

b. Go to File → Scripts → Embed Links 

c. Set the work folder to be “Ready” 
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Preprocessing Images With Adobe Photoshop 

 

Photoshop can be used to automatically preprocess all images in a folder the same way.  This step 

demonstrates how to do this “batch processing” in Photoshop.  Images can also be preprocessed one 

at a time. 

 

1. Place all of the images in the set into a folder called “Input”. 

2. Open one image in Photoshop. 

3. Create a new “Action”.  A Photoshop “Action” records all of the user’s actions so they can 

be applied to other files later on. 

a. Ensure that the “Actions” window is visible:  Go to Window → Actions and ensure 

that this option is checked. 

b. In the Actions window, click on the “New Action” button to create a new action (see 

image below). 

c. In the “New Action” popup window, choose a name for the action. 

d. When done, press “OK” to start recording actions.  Notice that the “Record” button 

in the “Actions” window turns red when recording. 

 

 

 

 

 
The “New Action” button (shown circled in the lower right) and the “New Action” popup window. 
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Preprocessing Images With Adobe Photoshop (continued) 

 

4. Change the color threshold of the image to thicken lines. 

a. Open the “Threshold” popup window:  Image → Adjustments → Threshold (see top 

image below): 

i. Adjust the slider until lines in the image are uniformly solid (see bottom 

image below). 

ii. When done, press “OK” to save changes. 

b. On the “Actions” window, press the black “Stop” button to stop recording actions 

(see image on next page). 

 

 
How to navigate to the “Threshold” dialog box. 

 

 
The “Threshold” dialog box. 
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Preprocessing Images With Adobe Photoshop (continued) 

 

 

 
The “Stop” button is circled in the “Action” window. 

 

5. Use the “Batch” function to apply the Action to the rest of the images. 

a. File → Automate → Batch to open the “Batch” popup window (see images on next 

page): 

i. Action:  Select the action you created from the list. 

ii. Source:  Folder 

iii. Underneath the “Source” field, use the “Choose” button to navigate to the 

“Input” folder. 

iv. Destination:  Save and Close 

v. When done, press “OK” to start automatic batch processing. 
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Preprocessing Images With Adobe Photoshop (continued) 

 

 

 
How to navigate to the “Batch” command. 

 

 

 

 
The “Batch” dialog box. 
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Appendices 
 

Project Overview 

 

The Tactile Graphics Project aims to increase universal benefit from graphical images (i.e., line 

graphs, bar charts, illustrations, etc.). It is a multidisciplinary project with researchers and 

practitioners from UW's Department of Computer Science and Engineering, Access Technology 

Lab, and DO-IT. Our goal is to enable K-12, college, undergrad, and graduates students who are 

blind to have full access to mathematics, engineering, and science. We have developed the Tactile 

Graphics Assistant software which, when combined with off-the-shelf software applications, 

enables the rapid translation of visual graphics to a tactile form. 

 

Research includes: 

 

 Developing machine learning algorithms that can easily classify images for processing 

 Developing image segmentation algorithms that can extract textual labels in graphical 

images 

 Developing algorithms to effectively place Braille text 

 Developing a tool (the Tactile Graphics Assistant) to facilitate automated tactilization of 

graphical images 

 Developing a workflow to efficiently translate visual images to a tactile form 

 Developing resources to assist in transcriber training 

 Developing QR-code for text workflow (see below) 

 

Modifications to Use QR Codes 

 

An alternative to Braille for text in images is to use QR-codes which are public code for which 

readers are freely available. An example of a QR-code is in the figure below. 

 

 
“This is an example of a QR-code” 

 

There are several advantages of QR-codes over Braille.  First, QR-codes generally take less area 

than Braille, allowing for the inclusion of more text in a tactile graphic.  Second, QR-codes would 

allow these who do not know Braille to have access to text in tactile graphics.  A disadvantage of 

QR-codes is the time to find and recover the text stored in them with a smartphone QR-code reader. 

An example of a tactile graphic with QR-codes instead of Braille is shown below.  
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A tactile graphic with QR-codes.  

 

In order to modify TGA to use QR-codes instead of Braille, two steps in the TGA process need to 

be replaced. Step 5 translates the text labels into Braille. This step will need to be replaced with 

generating QR-codes for the text. Step 7 will need to be replaced with the QR-code placement. 

Currently the QR-codes are manually being cut out and glued on top of the tactile graphics in their 

appropriate locations. In the future it is possible to print the QR codes using an ink printer directly.  

If this is done, tactile markers need to be added to the image to allow the QR codes to be found. A 

potential marker is ^ with the QR code lining up below the opening. 

 

Alternative Software 

 

The software other that we have used were the best available at the time we developed the Tactile 

Graphics Workflow.  The Adobe Creative Suite (Photoshop, Illustrator), Omnipage, and Braille 

translation software are relatively expensive.  The make the workflow possible, the software should 

have scripting ability so that many images can be processed in one run.  New scripts would have to 

be written to use any alternative software.  Modifications to the workflow may be necessary to 

accommodate these alternatives. Below is a list of alternative software that is free and  

downloadable from the web. 

 

 Photoshop  Gimp (http://www.gimp.org/) 

o Gimp has a variety of scripting resources and options 

o Script-Fu and Python are the two most common possibilities mentioned, but other 

languages are possible. 

o http://docs.gimp.org/en/gimp-concepts-script-fu.html  

o http://www.gimp.org/docs/python/index.html  

o http://gimpbook.com/scripting/  

o Also has repository of already created scripts to check out: http://registry.gimp.org  

 Illustrator  Inkscape (http://inkscape.org/) 

o It appears that there is no documentation for scripting in Inkscape, just forums that 

have examples 

http://www.gimp.org/
http://docs.gimp.org/en/gimp-concepts-script-fu.html
http://www.gimp.org/docs/python/index.html
http://gimpbook.com/scripting/
http://registry.gimp.org/
http://inkscape.org/
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o http://wiki.inkscape.org/wiki/index.php/Script_extensions  This has some basic 

information about scripting as well as a couple of links with some addition scripting 

information 

 Omnipage  Tesseract (https://code.google.com/p/tesseract-ocr/) 

o It appears that Tesseractdoes not support batch processing, but there are some GUIs 

built on top of it that do or many people just wrote their own batch script. Here is a 

possibility: http://vietocr.sourceforge.net/  There may be others as there are many 

systems built on top of it 

 

Available Books 

 

 Computer Architecture: A Quantitative Approach, 3rd Edition 

Hennessy and Patterson 

2002 Elsevier 

 Advanced Mathematical Concepts, Precalculus with Applications 

Gordon-Holliday, et al. 

1999 Glencoe/McGraw-Hill 

 An Introduction to Modern Astrophysics 

Carroll and Ostlie 

1996 Addison-Wesley 

 Discrete Mathematical Structures 

Kolman, Busby and Ross 

2003 Prentice Hall  

 Introduction to the Theory of Computation: Second Edition  

Michael Sipser  

2006 Thomson Learning 

 

Please visit our website for more information: 

http://tactilegraphics.cs.washington.edu 

 

Contact Information 

 

The Tactile Graphics Project website: 

http://tactilegraphics.cs.washington.edu 

 

To download the executable for the TGA, please register at this website: 

http://depts.washington.edu/ventures/UW_technology/Express_Licenses/tga.php 

 

To obtain the source code for the TGA, please contact: 

UW Tech Transfer Digital Ventures 

UW Tech Transfer 

4311 11th Avenue NE Suite 500 

Seattle, WA 98105-3451 

Phone: (206) 616-3451 

Fax: (206) 616-3322 

E-mail: license@u.washington.edu 

 

 

 

http://wiki.inkscape.org/wiki/index.php/Script_extensions
https://code.google.com/p/tesseract-ocr/
http://vietocr.sourceforge.net/
http://tactilegraphics.cs.washington.edu/
mailto:license@u.washington.edu

